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IF Statement 
The Excel IF Function returns one value if a specified condition evaluates to TRUE, or another value if it evaluates to 
FALSE. In this example, each employee received a Job rating with 1 being the worst rating and 5 being the best rating. 
Each employee that has a job rating of 4 or 5 will receive a $250 bonus. The IF function can run the logical reference 
(greater than 3) and put the number 250 in each cell that meets that requirement. If the job rating is less than 4, the IF 
statement will put a zero in the cell.   

 
 

1. From the Formulas Tab >> Function Library select Logical and then IF. 

 
2. The Function Arguments window should be filled out as shown below.  
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3. Use the AutoFill handle to copy the function.  

 
 

IFS 
Tired of typing complicated, nested IF functions? The IFS function is the solution. With this function, conditions are 
tested in the order that you specify. If passed, the result is returned. You can also specify an else "catch all" if none of 
the conditions are met. To specify a default result, enter TRUE for your final logical_test argument. We can use the IFS 
function to apply bonuses in the table below.  A Job rating greater than 3 will receive $1000, a Job rating greater than 1 
will receive $500 and all others will receive $0.  
 

Job Rating Bonus 

5 $1000 

4 $1000 

3 $500 

2 $500 

1 $0 

 
1. Formulas Tab >> Logical >> IFS 
2. Enter in your logical test: E2>3 
3. Value_if_true1: 1000 

 
4. Logical_test2: E2>1 
5. Value_if_true2:  500 

 
6. Logical-test3: True 



 5  

7. Value_if_true3: 0 

 
 

VLOOKUP 
There are several Excel functions that you can use to look up and return information within a table. The most popular 
function for most users is VLOOKUP, which searches the first column of a range of cells and then returns a value from 
any cell on the same row.  
 
The inherent limitation of VLOOKUP is that whatever value you want to return must be to the right of that first search 
row.  
=VLOOKUP(lookup_value,table_array,col_index_num,[range_lookup])  

 
 

 
In this example we are using the Code in column B as the lookup value. Our table array is an absolute reference to cells 
F3:H6. Column F provides the lookup reference in the left most column of the table array, referred to as column 1. 
Column G, referred to as column 2, will return the product name. Column H, referred to as column 3, will return the 
product price.  
 

XLOOKUP 
The Excel XLOOKUP function is a modern and flexible replacement for older functions like VLOOKUP, HLOOKUP, and 

LOOKUP.  XLOOKUP supports approximate and exact matching, wildcards (* ?) for partial matches, and lookups in 

vertical or horizontal ranges. 

Unlike the other match functions, XLOOKUP supports an optional argument called not_found that can be used to 

override the #N/A error when it would otherwise appear. Typical values for not_found might be "Not found", "No 

match", "No result", etc. When providing a value for not_found, enclose the text in double quotes (""). 
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Match type 

By default, XLOOKUP will perform an exact match. Match behavior is controlled by an optional argument 

called match_type, which has the following options: 

Match type Behavior 

0 (default) Exact match. Will return #N/A if no match. 

-1 Exact match or next smaller item. 

1 Exact match or next larger item. 

2 Wildcard match (*, ?, ~) 

 
Search mode 

By default, XLOOKUP will start matching from the first data value. Search behavior is controlled by an optional 

argument called search_mode, which provides the following options: 

Search mode Behavior 

1 (default) Search from first value 

-1 Search from last value (reverse) 

2 Binary search values sorted in ascending order 

-2 Binary search values sorted in descending order 

Binary searches are very fast, but data must be sorted as required. If data is not sorted properly, a binary search can 

return invalid results that look perfectly normal. 

1. In this example we will use XLOOKUP instead of VLOOKUP to find the Employee Name and Department by 

entering the Employee ID in cell A2.  NOTE: the data (A4:C14) is a table.  This will allow for a user to add/delete 

data into the table and have the range automatically updated.  

 

https://exceljet.net/glossary/wildcard
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2.  Click in cell B2 (Employee Name).  Formulas Tab >> Lookup and Reference >> XLOOKUP.  

 

 

3. The Lookup_value is the Employee ID – Cell A2. 

 

4. Click in Lookup_Array. Highlight the Employee ID Range below A4:A14 – notice the range is a table reference 

instead of an exact cell range.  

 

5. Click in Return_array.  This is the column of data you want to return which is the Employee Name (B4:B14).  

 

6. If_not_found can be used to return text such as “Employee Not Found” instead of the error message #N/A. 
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7. Click OK.   

 

8. Click in C2 to use XLOOKUP to find the Department. Formulas Tab >> Lookup and Reference >> XLOOKUP. The 

following should be entered:   Lookup_Value (A2), Lookup_array (A4:A14), Return_array (C2:C14), If_not_found 

(“”) – this returns a blank cell.  CLICK OK.  

 

9. Change the Employee ID to lookup a new Employee Name and Department.  

 

10. Results if an employee ID does not exist.  

 

CONCAT 
This new function is like CONCATENATE, but better. First, it's shorter and easier to type. But it also supports range 
references, in addition to cell references. The CONCAT function combines the text from multiple ranges and/or strings. 
Formulas Tab >> Text >> CONCAT 

 
 

 
 

  



 9  

TEXTJOIN 
This function combines text from multiple ranges, and each item is separated by a delimiter that you specify. 

 
 

 
 

MAXIFS 
The MAXIFS function returns the maximum value among cells specified by a given set of conditions or criteria: 
numbers, dates, text, etc. 
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MINIFS 
The MINIFS function returns the minimum value among cells specified by a given set of conditions or criteria. 

 
 
Results 

 
 

SWITCH 
The SWITCH function evaluates one value (called the expression) against a list of values and returns the result 
corresponding to the first matching value. 
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Date & Time Functions 
NOW & TODAY FUNCTIONS 
Manipulating Dates, Times & Text 

NOW 
In Excel, the NOW function returns the current system date and time. This function will refresh the date/time value 
whenever the worksheet recalculates.  The syntax for the NOW function is: NOW() 

1. Click in the cell you wish the current date to appear.  

2. Type in the following: =NOW()  and press the enter key. 

 

 

TODAY 
In Excel, the TODAY function returns the current system date. This function will refresh the date whenever the 
worksheet recalculates.  The syntax for the TODAY function is: TODAY() 

1. Click in the cell you wish the current date to appear.  

2. Type in the following: =TODAY()  and press the enter key. 

 

 

YEARFAC 
Age from Birthday 
You can calculate a person’s age from their birthdate by using the INT, YEARFRAC, and TODAY functions.  
=(INT(YEARFRAC(birthdate,TODAY())) 
YEARFRAC calculates a decimal number representing the fraction of a year between two dates. The INT function rounds 
down that number to the integer value. The TODAY function always calculates the age in comparison to the current 
date.  

1. Formulas Tab >> Math & Trig >> INT 
 

2. Use the name box dropdown >> More Functions and find the YEARFRAC Function. 
  

Date Keyboard Shortcuts 
• Current Date Ctrl + ; 

• Current Time Ctrl + Shift + ; 
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3. The Start Date is the Birth Date. The End Date is Today().   

 
4. Click OK.  

  
 

NETWORKDAYS FUNCTION 
Returns the number of whole working days between start_date and end_date. Working days exclude weekends and 
any dates identified in holidays. Use NETWORKDAYS to calculate employee benefits that accrue based on the number 
of days worked during a specific term. 
 

1. Click Formulas>>Date & Time>>NETWORKDAYS 

2. Enter in the following cell references. 
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3. Click OK. Your result will be displayed. 

 
NOTE: if you want the word Days to be displayed in the cell along with the number, click in the formula bar and 

use the ampersand (&) to add text. Text needs to be wrapped in quotes “ Days”.  

 
 

 
Remarks 

• Microsoft Excel stores dates as sequential serial numbers so they can be used in calculations. By default, 

January 1, 1900 is serial number 1, and January 1, 2008 is serial number 39448 because it is 39,448 days after 

January 1, 1900.  
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WORKDAY FUNCTION 
WORKDAY() 
Occasionally, it may be useful to count ahead based on workdays (Monday-Friday) instead of all 7 days of the week… 
For that, Excel has provided WORKDAY.  
The start_date is as above. 
The days input is the number of workdays ahead (or behind) of the present day you would like to move. 

 
The [holidays] input is optional, but lets you disqualify specific days (like Thanksgiving or Christmas, for example), which 
might otherwise fall during the work week. 
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Weekday  
The WEEKDAY function returns a number from 1 (Sunday) to 7 (Saturday) representing the day of the week of a date. 
The 6 in this example means it is Friday.  =Weekday(A1) 

      
 
You can custom format the number using ddd (Fri) or dddd (Friday). To do so, right mouse click the cell and select 
Format Cells. Select Custom. Enter in ddd or dddd. Click OK.  

           
 

EDATE 
The EDATE Function returns a date that is a specified number of months before or after a supplied start date. 
Example: New employees are on a probationary period for a predetermined number of months. The probationary 
period length varies according to each job. Use EDate to figure out the end date of the probationary period.  
 
From the Formulas Tab >> Date & Time, select EDATE. Select the start date (this date should be in your worksheet) and 
select the number of months (this date can be entered in manually as well). Click OK.  
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EOMONTH 
Returns a date that is the last day of the month which is a specified number of months before or after an initial 
supplied start date.  
Example: New employees are on a probationary period for a predetermined number of months and ends on the last 
day of the month. The probationary period length varies according to each job. Use EOMONTH to figure out the end 
date of the probationary period.  
 
From the Formulas Tab >> Date & Time, select EOMONTH. Select the start date (this date should be in your worksheet) 
and select the number of months (this date can be entered manually as well). Click OK.  
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Troubleshooting Formulas 
 

TRACE PRECEDENTS AND DEPENDENTS 
Trace Precedents 
The Trace Precedents command is used to backtrack through all the cells that are used to calculate the current formula.  

1. Formulas Tab >> Formula Auditing >> Trace Precedents 

 
2. Results: 

 
Each blue dot corresponds to a value used in the formula. An arrow points to the end value.  If you click the 
Trace Precedents command again, any values that were used to calculate any precedent formulas are also 
highlighted. This means you can keep clicking Trace Precedents to go back multiple levels of precedents. 

3. You can remove these arrows by clicking Remove Arrows in the Formula Auditing group:

 
 
Trace Dependents 
The Trace Dependents command works the opposite way of Trace Precedents: it highlights all the items that depend on 
the value in the current cell. Excel will alert you if you click this command when it doesn’t apply: 

 
1. Formulas Tab >> Formula Auditing Group >> Trace Dependents.  
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2. Results 

 
This command can also be clicked multiple times to continue stepping through each level of dependency. 

 
Remove Arrows 

1. You can remove these arrows by clicking Remove Arrows in the Formula Auditing group:

 
 

SHOW FORMULAS 
The Show Formulas command will show all the formulas in the worksheet rather than their computed value. This is a 
toggle command that also expands the column widths, so the formulas are easier to read: 

 
This mode is very useful when you are creating formulas for a large sheet. You can ensure that the formulas are correct 
before adding or computing data. Viewing formulas also makes it easier for others to view your work and understand 
how values are calculated instead of clicking cells one at a time and looking at the formula bar. 
Click this command again to show the calculated values. The columns will also return to their normal widths. 
 

EVALUATE FORMULA 
As we have seen by examining the other commands in this section, there are a number of commands you can use to 
easily and accurately track what a formula is doing. The Evaluate Formula command takes this concept one step further 
by showing you every single calculation that was used to reach a particular value. This command is extremely useful 
for making sure a complex formula is doing exactly what you intend it to do, or for finding that one small piece that is 
causing your calculation to fail along the way. 
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Here, we have selected a value in the Profit column of our sales worksheet and will step through the formula: 

 

 
The Evaluate Formula dialog box will appear and show the formula that will be evaluated: 

 
 
Click Evaluate to step into the first part of the formula. It turns the first reference into the number.   
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Now, the next value is highlighted and the option to Step In is available again. Click Evaluate to continue checking and 
evaluating the formula: 

 
Eventually, the checker will step through all the calculations one at a time before showing you the final step: 

 

        
Clicking Evaluate once more will perform the final calculation and show the result. Clicking Evaluate a final time will 
start the process over from the beginning. 
 

List Management 
SORT BY VALUES, CELL COLOR, FONT COLOR, CELL ICONS 

1) If several cells in a list have a specific cell color, font color, etc. you can right mouse click >> Sort and select 
from the list.  
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2) In this example Put Selected Cell Color On Top was selected.  

                    

NUMBER, TEXT, AND DATE FILTERS 
1) You can use AutoFilter (Home Tab >> Editing Group >> Sort & Filter 

 
2) Each filter dropdown contains content specific filters.  

a. Text Filters 

 
b. Number Filters 
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c. Date Filters 

 

SEARCH CRITERIA 
1) You can type in specific search criteria in the Search Text box.  Items will be automatically selected based on 

the criteria you provide.  

      
2) You can also use the select checkmarks to select the criteria you want to filter.   

 

CREATE SUBTOTALS 
1) The first step in creating subtotals is to sort by the field you want the subtotals grouped by. In this example we 

have sorted by Status and will have subtotals add up the amount of salary in each Status group: Full, Half-Time, 
Contract, Hourly. 

 
To sort, click in one cell in the column you wish to sort the entire list >> Home Tab >> Editing Group >> Sort and 
Filter >> Sort and Filter.  
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2) To insert Subtotals, Data Tab >> Outline Group >> Subtotal 

 
 

3) Select the column you sorted by at the At each change in: dropdown.  Here we will select Status.  

 
 

4) We will select Sum in the Use Function: dropdown.  Notice you can find average, max, min, etc., as well.  

 
5) Select where you want to add the subtotal.   

 
6) You will now have outline levels you can click on the right-hand side of the data.  

Level 1 will display the Grant Total.  
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7) Level 2 displays subtotals and the grand total.  

 
8) Level 3 displays all data. 

 
 

REMOVE SUBTOTALS 
1) Data Tab >> Outline Group >> Subtotal 

 
2) Remove All 
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Creating a Table  
There are two ways to create a table. You can either insert a table directly in the default table style or you can convert 
an existing range into a table. The second approach is by far the most common:  

1. On a worksheet, click anywhere in your list of information.  
2. On the Home tab, within the Styles group, select Format at Table. 
3. A Create Table dialog box will appear. Your selected range appears as an absolute cell reference. Your range 

will already be selected and displayed in the Where is the data for your table? 

 
4. If your selected range contains data that you want to display as table headers, select the My table has headers 

check box.  
5. Click the OK command button to create the table.  
6. When you have an Excel table selected, you will have access to a Table Tools contextual tab with a single 

Design sub-tab.  
Each time you create a table, Excel creates a default table name in the Properties group (e.g., Table1, Table2, etc.). The 
scope of the table name is for the entire workbook. 
 

ADD A TOTAL ROW 
1. Click anywhere in the table 
2. On the Design Tab, within the Table Style Options group, select Total Row check box.  

   

 
The total row appears as the last row in the table and displays the word Total in the left most cell. 

3. In the total row, click the cell in the column for which you want to calculate a total, and then click the 
dropdown that appears. 

4. In the dropdown list, select the function that you want to use to calculate the total. 
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CONVERT TO NORMAL RANGE 
1) Click with in the table.  
2) Table Design Tab >> Tools Group >> Convert to Range 

  
3) Click Yes to confirm.  

 
4) Any formatting will stay.   

 

Protecting / Unprotecting Worksheets 
Protecting a worksheet prevents editing of cells (unless they are unlocked) and can also 
prevent other commands from being used. 
 
Cell Formatting 
We first unlock the cells we want users to be able to change.  
 

1) Select the cell(s) >> Right mouse click >> Cell Format 
2) Protection Tab >> Deselect the Locked checkmark.  

 
1. Turn on protection by choosing Review >> Protect sheet. Select specific actions to permit. A password is 

optional. 

  
2. To unprotect, choose Review >> Unprotect Sheet. Enter the password if prompted 
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PASSWORD PROTECT WORKBOOK 
This will protect users from deleting, moving, renaming worksheet tabs.   

1. Review Tab >> Protect Workbook. 
 

2. Enter in your password.  Click OK 

 
 

3. Confirm your Password. Click OK. 
 

4. Users will not be able to create new worksheets, add, rename, hide/unhide worksheets.  
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PASSWORD PROTECT YOUR ENTIRE FILE 
1. Click the File Tab >> Info >> Encrypt with Password.   

NOTE: you can protect your current sheet and workbook structure here as well.   

 
2. Enter and confirm your password.  

 
3. Excel will inform you that a password is required.  
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Linking Data  
Linking allows data stored on a worksheet to be referenced by another worksheet. This can be 
within the same workbook, or in separate workbooks.  
Linking worksheets 

1. Open the file containing worksheets that you want to link together. 
2. Copy the cell you wish to link to another worksheet. 
3. Switch to that worksheet and select the desired cell. 
4. Right mouse click >> Select the Paste Link option.   

 
5.  

 
If the data is changed for a source cell, it is automatically updated in the destination cell, provided the changes 
to the source are saved. 

 

EDIT LINKS 
One file could be linked to one or more other files through formulae.  During the course of time, as these workbooks 
get updated / changed, there could be a need to change the links in these workbooks.  Changing the source link allows 
the user to change the location of the source where the data exists or to change the link to a new workbook altogether. 
 
To change the source link, you must use the “Edit Links” option.  This option gives the user a view of all the other files 
the current file is linked to, so that the user can update or remove the links. 

1. From the Data Tab select Edit Links.  

 
2. This window allows you to Change the source, open the 

source, break the link, or check the status. 
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Data Validation  
To limit entry to a list of values:  

1. Ahead of time, enter the possible values on the same worksheet but far away from anywhere that will contain 
values or be subjected to possible deletion. 

2. Click in the cell(s) where you want to control what gets entered. 
3. Select Data ribbon > Data Tools group > Data Validation  
4. On the Settings tab, select List under Allow:  
5. Enter or select the source for possible responses. 

             
6. Under Input Message, you can provide a prompt to assist during data entry:  

 
7. Under Error Alert, you can provide remedial support to encourage the correct selection. You can also choose to 

make the error only a warning instead of refusing to take their value. 
8. Click on OK to finalize your choices. 

 
To restrict entry to other specific types:  
At times it is useful to set cells to only accept certain kinds of information. These are things such as whole numbers, 
decimals, and dates.  

1. Click in the cell(s) where you want to control what gets entered  
2. Select Data ribbon > Data Tools group > Data Validation  
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Charting Tools 
1. Insert Tab >> Charts group >> select a chart (Line, Pie, Bar). 

 
2. Excel offers a Recommended Charts tool.  The way this works is very intuitive and is based on the data you 

have selected. For instance, a table with a simple layout of two rows and four columns will result in a 
suggestion of a simple chart such as a line chart. However, you can always choose a different chart if you don’t 
like the results.  

        
 

3. Change the chart type by selecting Chart Tools >> Design Tab >> Change Chart type. 

 
 

4. Select from the left column (Column, Line, Bar). Select the chart type on the right. Click OK.  

 
 
  

Recommended charts are available 
from the INSERT >> Charts Group >> 
Recommended Charts. 
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Switch Row/Column 
If you want to switch the Legend and the Axis information, use Switch Row/Column. 

1. Select the Chart. Design Tab >> Data Group >> Switch Row/Column 

 

     
 
Chart Elements 
Use chart elements to move the Legend, add Data Labels and customize your chart axis. 

 
 
Chart Style 
Chart Styles allows you to change the style and colors of your chart.   
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Chart Filter 
Chart filters allows you filter out data. 

 
 
 

SAVING A CHART AS A TEMPLATE 
Once you get your chart looking just the way you like it, you can save the chart type, colors, and formatting as a 
template that can be reused to make on future charts. 
 
To save this chart as a template, right mouse click the chart (either in the plot area or chart area) and choose Save as 
Template. This will display a Save Chart Template dialogue box; it’s virtually identical to the regular Save dialog. Just 
enter an appropriate name for your chart template and then click the Save button. By default, the templates will be 
saved in an Excel chart folder. Then, you can apply the template right away by selecting it from the Templates folder.  

         
If you select Templates in the pane on the left of the box, you will see the chart template that you saved displayed on 
the right side. Just click the template icon to apply the template to the selected data. 
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CREATE CHARTS WITH KEYBOARD SHORTCUTS 
You can quickly add charts to your workbook using two different keyboard shortcuts.  

1. To add a chart into the worksheet that is currently active, select the data you wish to chart and press  
Alt + F1.  

 
2. To insert a chart into a new worksheet in your workbook, select the data you wish to chart and press the F11 

key. This chart your data and place in a worksheet of its own.  

 
 
Change the Default Chart Type 
You can change the default chart type that is inserted into your worksheets. 

1. Open the Change Chart Type dialog box by inserting a chart. Then, from the Chart Tools Ribbon Option, on the 
Design Tab, in the Type Group, click Change Chart Type. 

 
 

 
2. In the Change Chart Type dialog box, right mouse click the chart you wish to set as your default. Select Set as 

Default Chart. 

 
 

3. Click OK.  
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Dates 
Excel will choose how it charts dates.  If you want each date to show up on your chart you must change the Axis option 
to Text.  

 
1. Double click the Date Axis.   Change the Axis option to Text axis.  

 
2. Results: 

 
 
Use a Table to Create a Chart 
Format your source data as a table, then create a chart based on that table. When you add more data below the table, 
it will automatically be included in both the table and the chart, keeping everything consistent and up to date. 


